Discussion:
No files dumped for share on windows 2008 server client
(too old to reply)
thomas83
2009-04-13 13:37:04 UTC
Permalink
Hi,

I have installed backuppc on ubuntu 8.10 and added an windows client.
When starting backup everything seems to go fine but it stops quit fast and saying backup failed (No files dumped for share installshare)

I have tested with diffierent users and shares, on C$ it can't read anything. But on the intallshare it can read all the folders but not the files inside them.

I only uses SMB share and haven't installed rsync on my windows 2008 server. I tried but then i got an blue screen.

Here are the error log
Running: /usr/bin/smbclient \\\\fs01\\installshare -I 192.168.100.10 -U FREEUP\\backuppc -E -d 1 -c tarmode\ full -Tc -
full backup started for share installshare
Xfer PIDs are now 13968,13967
[ skipped 2 lines ]
NT_STATUS_OBJECT_PATH_NOT_FOUND opening remote file \Applikasjoner\ADModify.NET\23282\ADModcmd.exe (\Applikasjoner\ADModify.NET\23282\)
NT_STATUS_FILE_IS_A_DIRECTORY opening remote file \Windows\win.ctx (\Windows\)
NT_STATUS_FILE_IS_A_DIRECTORY opening remote file \Windows\win.ini (\Windows\)
[ skipped 23 lines ]
tarExtract: Done: 0 errors, 0 filesExist, 0 sizeExist, 0 sizeExistComp, 0 filesTotal, 0 sizeTotal
Got fatal error during xfer (No files dumped for share installshare)
Backup aborted (No files dumped for share installshare)
Not saving this as a partial backup since it has fewer files than the prior one (got 1 and 0 files versus 1)

Since it was about 1000 lines i only included the top and the bottom.,
And here are the XferLOG

Running: /usr/bin/smbclient \\\\fs01\\installshare -I 192.168.100.10 -U FREEUP\\backuppc -E -d 1 -c tarmode\ full -Tc -
full backup started for share installshare
Xfer PIDs are now 13968,13967
Domain=[FREEUP] OS=[Windows Server (R) 2008 Standard 6001 Service Pack 1] Server=[Windows Server (R) 2008 Standard 6.0]
tarmode is now full, system, hidden, noreset, verbose
NT_STATUS_OBJECT_PATH_NOT_FOUND opening remote file \Applikasjoner\ADModify.NET\23282\ADModcmd.exe (\Applikasjoner\ADModify.NET\23282\)
NT_STATUS_OBJECT_PATH_NOT_FOUND opening remote file \Applikasjoner\ADModify.NET\23282\ADModify.exe (\Applikasjoner\ADModify.NET\23282\)
NT_STATUS_FILE_IS_A_DIRECTORY opening remote file \Windows\win.ctx (\Windows\)
NT_STATUS_FILE_IS_A_DIRECTORY opening remote file \Windows\win.ini (\Windows\)
tar: dumped 636 files and directories
Total bytes written: 0
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD/MSFT
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD/MSFT/FONTS
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD/MSFT/MGMT
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD/MSFT/MGMT/CIMV2R5
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD/MSFT/MGMT/DOMREN
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD/MSFT/MGMT/IAS
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD/MSFT/MGMT/PBA
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD/MSFT/NET
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD/MSFT/NET/TOOLS
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD/MSFT/USMT
create d 755 0/0 0 Windows/Servere/Windows 2003/en_windows_server_2003_standard/VALUEADD/MSFT/USMT/ANSI
create d 755 0/0 0 Windows/Servere/Windows 2003/Windows Server 2003 Service Pack 2 (32-bit x86)
create d 755 0/0 0 Windows/Servere/Windows 2003 R2
create d 755 0/0 0 Windows/Servere/Windows 2008
create d 755 0/0 0 Windows/Servere/Windows 2008/X64
create d 755 0/0 0 Windows/Servere/Windows 2008/X86
create d 755 0/0 0 Windows/Servere/Windows 2008 Small business server
create d 755 0/0 0 Windows/SQL - Servere
create d 755 0/0 0 Windows/SQL - Servere/en_sql_2005_std_x86
create d 755 0/0 0 Windows/system
tarExtract: Done: 0 errors, 0 filesExist, 0 sizeExist, 0 sizeExistComp, 0 filesTotal, 0 sizeTotal
Got fatal error during xfer (No files dumped for share installshare)
Backup aborted (No files dumped for share installshare)
Not saving this as a partial backup since it has fewer files than the prior one (got 1 and 0 files versus 1)


Does anybody have a tip for me to fix this?

Regards,
Thomas B[/quote]

+----------------------------------------------------------------------
|This was sent by ***@borgedata.com via Backup Central.
|Forward SPAM to ***@backupcentral.com.
+----------------------------------------------------------------------
thomas83
2009-04-17 21:12:59 UTC
Permalink
I have tried out several things now.

Rsyncd won't work in windows 2008 it seems, the service want start.
Just get an unexpected error when starting it.

Haven't find any solution on the web for that yet.

I have figured out that backuppc doens't like dfs share and c$ share.
But if i choose to share a new folder called fex share i can backup both folder and files.

And if i choose to share my c station sow it becomes \\pc\c

I have tried to use smbclient locally on the backuppc server and manually made a tar backup of the dfs share and get the same error.
But to copy and file from the share to the backuppc with smbclient works fine.

If i mount the share on the local backuppc and then take backup of that share it works.

Sow now im really stuck on what to do.

I have sarched high and low on both smb and backuppc issues but nobody has tried it on windows 2008 it seems.

Sow hopefully somebody out there can help me with this issue
Why can't we backupwindows 2008 just like windows 2003 and XP?

+----------------------------------------------------------------------
|This was sent by ***@borgedata.com via Backup Central.
|Forward SPAM to ***@backupcentral.com.
+----------------------------------------------------------------------
Les Stott
2009-04-18 08:43:36 UTC
Permalink
Post by thomas83
I have tried out several things now.
Rsyncd won't work in windows 2008 it seems, the service want start.
Just get an unexpected error when starting it.
Haven't find any solution on the web for that yet.
Which rsync did you use to install on the windows 2008 server? cygwin
rsync 3.0.4 is broken and wont run. You need to downgrade to 2.6.9.

I successfully use rsyncd 2.6.9 from cygwin on windows 2008.

Regards,

Les
Jeffrey J. Kosowsky
2009-04-19 01:45:10 UTC
Permalink
Post by Les Stott
Post by thomas83
I have tried out several things now.
Rsyncd won't work in windows 2008 it seems, the service want start.
Just get an unexpected error when starting it.
Haven't find any solution on the web for that yet.
Which rsync did you use to install on the windows 2008 server? cygwin
rsync 3.0.4 is broken and wont run. You need to downgrade to 2.6.9.
I successfully use rsyncd 2.6.9 from cygwin on windows 2008.
Regards,
Les
Is this problem specific to Windows 2008? Because I use cygwin
rsync-3.0.4 just fine on Windows XP.
Gérald Becker
2009-04-19 08:27:36 UTC
Permalink
Post by Jeffrey J. Kosowsky
Post by Les Stott
Post by thomas83
I have tried out several things now.
Rsyncd won't work in windows 2008 it seems, the service want start.
Just get an unexpected error when starting it.
Haven't find any solution on the web for that yet.
Which rsync did you use to install on the windows 2008 server? cygwin
rsync 3.0.4 is broken and wont run. You need to downgrade to 2.6.9.
I successfully use rsyncd 2.6.9 from cygwin on windows 2008.
Regards,
Les
Is this problem specific to Windows 2008? Because I use cygwin
rsync-3.0.4 just fine on Windows XP.
I tried to install properly rsyncd on windows 2008 too for days. I get
this unexpected error too, but before that, the service was running, but
was "buggy". 50% of my cpu was used by the idle service (i got a E8400).
I used rsyncd 2.6.8. Will continue tests. All is running fine on windows
xp clients. Will try on a vista client.
Post by Jeffrey J. Kosowsky
------------------------------------------------------------------------------
Stay on top of everything new and different, both inside and
around Java (TM) technology - register by April 22, and save
$200 on the JavaOne (SM) conference, June 2-5, 2009, San Francisco.
300 plus technical and hands-on sessions. Register today.
Use priority code J9JMT32. http://p.sf.net/sfu/p
_______________________________________________
BackupPC-users mailing list
List: https://lists.sourceforge.net/lists/listinfo/backuppc-users
Wiki: http://backuppc.wiki.sourceforge.net
Project: http://backuppc.sourceforge.net/
thomas83
2009-04-18 15:25:46 UTC
Permalink
[/quote]Which rsync did you use to install on the windows 2008 server? cygwin
rsync 3.0.4 is broken and wont run. You need to downgrade to 2.6.9.

I successfully use rsyncd 2.6.9 from cygwin on windows 2008.

Regards,

Les

[/quote]

Thanks Les, i have used the one that backuppc recommend.
It's version 2.6.8_0

I will try to install a newer version to see if it works better then.

Regards,

thomas

+----------------------------------------------------------------------
|This was sent by ***@borgedata.com via Backup Central.
|Forward SPAM to ***@backupcentral.com.
+----------------------------------------------------------------------
Les Stott
2009-04-19 07:51:28 UTC
Permalink
Post by Jeffrey J. Kosowsky
Post by Les Stott
Which rsync did you use to install on the windows 2008 server? cygwin
rsync 3.0.4 is broken and wont run. You need to downgrade to 2.6.9.
I successfully use rsyncd 2.6.9 from cygwin on windows 2008.
Regards,
Les
Is this problem specific to Windows 2008? Because I use cygwin
rsync-3.0.4 just fine on Windows XP.
i don't think so, never really delved too deeply into it, figured out
that 2.6.9 worked, so rolled back in anticipation of the next release
working.

Now that i come to think of it it may have been vista specific, but my
information is second hand, so i cant say for sure.

Regards,

Les
Jeffrey J. Kosowsky
2009-04-20 01:01:42 UTC
Permalink
Post by Les Stott
Post by Jeffrey J. Kosowsky
Post by Les Stott
Which rsync did you use to install on the windows 2008 server? cygwin
rsync 3.0.4 is broken and wont run. You need to downgrade to 2.6.9.
I successfully use rsyncd 2.6.9 from cygwin on windows 2008.
Regards,
Les
Is this problem specific to Windows 2008? Because I use cygwin
rsync-3.0.4 just fine on Windows XP.
i don't think so, never really delved too deeply into it, figured out
that 2.6.9 worked, so rolled back in anticipation of the next release
working.
Now that i come to think of it it may have been vista specific, but my
information is second hand, so i cant say for sure.
Regards,
Les
All I can say is that 3.0.4 works perfectly fine on XP - in fact, it
avoids some problems that I had with 2.6.9 where the rsync process
hung on certain filenames if I recall.
Les Stott
2009-04-20 09:19:34 UTC
Permalink
Post by Jeffrey J. Kosowsky
Post by Les Stott
Now that i come to think of it it may have been vista specific, but my
information is second hand, so i cant say for sure.
Regards,
Les
All I can say is that 3.0.4 works perfectly fine on XP - in fact, it
avoids some problems that I had with 2.6.9 where the rsync process
hung on certain filenames if I recall.
Just reporting back....

I was back on a client site today who use sbs 2008. So i re-tested using
rsync-3.0.4 and it appeared to work fine (when i had issues prior the
rsyncd service would start and stop).

So it may have just been a vista thing, i'll have to check that out further.

Regards,

Les

Continue reading on narkive:
Loading...